Vulnerability · Published Aug 12, 2026 · Assigned by GitHub_M
CVE-2026-73300Budibase: SQL Injection via `multipleStatements: true`
Critical 9.6
In plain English
A critical-severity SQL injection in budibase from Budibase. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities).
Severity (CVSS 3.1)9.6Critical
Exploit odds (30 days)0.6%top 52.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Budibase is an open-source low-code platform. Prior to 3.40.0, the MySQL integration component in Budibase is configured with multipleStatements: true, enabling execution of multiple SQL statements in a single query. Attackers can inject malicious SQL commands through user input fields, leading to complete database compromise. This vulnerability is fixed in 3.40.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @budibase/server | no fix listed | GHSA-q6x4-v3qx-85qw |
Affected products (as reported)
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/Budibase/budibase/security/advisories/GHSA-q6x4-v3qx-85qw x_refsource_CONFIRM
- https://github.com/Budibase/budibase/releases/tag/3.40.0 x_refsource_MISC