Vulnerability · Published Aug 12, 2026 · Assigned by GitHub_M

CVE-2026-73299Prompty: Server-Side Template Injection to Remote Code Execution in the @prompty/core Nunjucks Renderer

Critical 10.0

In plain English

A critical-severity code injection in prompty from microsoft. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)1.8%top 21.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Prompty is a markdown file format (.prompty) for LLM prompts. Prior to 0.1.5 and 2.0.0-beta.5, the TypeScript Nunjucks renderer evaluated untrusted .prompty template bodies with unrestricted JavaScript member access. An attacker-controlled template could traverse constructor and prototype properties to execute JavaScript in the host Node.js process. This issue is fixed in versions 0.1.5 and 2.0.0-beta.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@prompty/core0.1.5GHSA-w28w-gp39-m4p6
npm@prompty/core2.0.0-beta.5GHSA-w28w-gp39-m4p6

Affected products (as reported)

VendorProductVersions
microsoft prompty < 0.1.5>= 2.0.0-alpha.1, < 2.0.0-beta.5

Weakness: CWE-94, CWE-1336 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

References