Vulnerability · Published Aug 12, 2026 · Assigned by GitHub_M

CVE-2026-73292Semaphore UI: CSRF vulnerability on password change endpoint - No CSRF token or password confirmation

High 8.3

In plain English

A high-severity cross-site request forgery in semaphore from semaphoreui. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.2%top 85.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Semaphore UI is a web interface for managing DevOps tools. Prior to 2.18.21, the /api/users/{id}/password endpoint accepts a cross-site request using the authenticated user's semaphore session cookie without CSRF protection or current-password confirmation, allowing an unauthenticated attacker to change an administrator's or another user's password after user interaction. This issue is fixed in version 2.18.21.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/semaphoreui/semaphore0.0.0-20260707190631-c59c3dc9035bGHSA-8cj9-r88m-8945
Gogithub.com/semaphoreui/semaphore0.0.0-20260707190631-c59c3dc9035bGO-2026-6370

Affected products (as reported)

VendorProductVersions
semaphoreui semaphore < 2.18.21

Weakness: CWE-352, CWE-620 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

References