Vulnerability · Published Oct 14, 2026 · Assigned by GitHub_M

CVE-2026-73260Mongoose: Out-of-bounds Read via length-counter underflow in built-in TLS X.509 DER parser

High 7.5

In plain English

A high-severity out-of-bounds read in mongoose from cesanta. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.2%top 86.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14mongoose7.23+ds-1DEBIAN-CVE-2026-73260
Ubuntu:26.10mongooseno fix listedUBUNTU-CVE-2026-73260

Affected products (as reported)

VendorProductVersions
cesanta mongoose < 7.23

Weakness: CWE-125 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References