Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-73256Mongoose: HTTP/1.0 detection off-by-one enables request smuggling via chunked TE

Critical 9.1

In plain English

A critical-severity security flaw in mongoose from cesanta. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.4%top 61.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14mongoose7.22+ds-1DEBIAN-CVE-2026-73256
Ubuntu:26.10mongooseno fix listedUBUNTU-CVE-2026-73256

Affected products (as reported)

VendorProductVersions
cesanta mongoose < 7.22

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References