Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M

CVE-2026-73072Vim: Heap Buffer Overflow when Loading a Spell File

High 8.5

In plain English

A high-severity heap buffer overflow in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)0.1%top 98.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Vim is an open source, command line text editor. Prior to 9.2.0846, set_sofo() in src/spellfile.c reuses sl_sal_first[] without resetting values left by set_sal_first(), so a crafted spell file containing an SN_SAL section before an SN_SOFO section causes under-counted mapping lists and attacker-influenced writes beyond a heap allocation. This issue is fixed in version 9.2.0846.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10vim-X112:9.1.083-9.el10_2.20ALSA-2026:66336
AlmaLinux:8vim-X112:8.0.1763-31.el8_10.7ALSA-2026:66348
AlmaLinux:9vim-X112:8.2.2637-26.el9_8.21ALSA-2026:66366
AlmaLinux:10vim-common2:9.1.083-9.el10_2.20ALSA-2026:66336
AlmaLinux:8vim-common2:8.0.1763-31.el8_10.7ALSA-2026:66348
AlmaLinux:9vim-common2:8.2.2637-26.el9_8.21ALSA-2026:66366
AlmaLinux:10vim-data2:9.1.083-9.el10_2.20ALSA-2026:66336
AlmaLinux:10vim-enhanced2:9.1.083-9.el10_2.20ALSA-2026:66336
AlmaLinux:8vim-enhanced2:8.0.1763-31.el8_10.7ALSA-2026:66348
AlmaLinux:9vim-enhanced2:8.2.2637-26.el9_8.21ALSA-2026:66366
AlmaLinux:10vim-filesystem2:9.1.083-9.el10_2.20ALSA-2026:66336
AlmaLinux:8vim-filesystem2:8.0.1763-31.el8_10.7ALSA-2026:66348
AlmaLinux:9vim-filesystem2:8.2.2637-26.el9_8.21ALSA-2026:66366
AlmaLinux:10vim-minimal2:9.1.083-9.el10_2.20ALSA-2026:66336
AlmaLinux:8vim-minimal2:8.0.1763-31.el8_10.7ALSA-2026:66348
AlmaLinux:9vim-minimal2:8.2.2637-26.el9_8.21ALSA-2026:66366
AlmaLinux:10xxd2:9.1.083-9.el10_2.20ALSA-2026:66336
Alpine:v3.23vim9.2.0854-r0ALPINE-CVE-2026-73072
Alpine:v3.24vim9.2.0854-r0ALPINE-CVE-2026-73072
Debian:12vimno fix listedDEBIAN-CVE-2026-73072
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-73072
Debian:14vim2:9.2.0858-1DEBIAN-CVE-2026-73072
Rocky Linux:10vim2:9.1.083-9.el10_2.20RLSA-2026:66336
Rocky Linux:8vim2:8.0.1763-31.el8_10.7RLSA-2026:66348
Rocky Linux:9vim2:8.2.2637-26.el9_8.21RLSA-2026:66366
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.35UBUNTU-CVE-2026-73072
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.35USN-8657-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.19UBUNTU-CVE-2026-73072
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.19USN-8657-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.8UBUNTU-CVE-2026-73072
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.8USN-8657-1

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0846

Weakness: CWE-122, CWE-787 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References