Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M
CVE-2026-73070Vim: Stack Buffer Overflow in the Vim Socket Server
Medium 6.8
In plain English
A medium-severity stack buffer overflow in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | vim | 9.2.0854-r0 | ALPINE-CVE-2026-73070 |
| Alpine:v3.24 | vim | 9.2.0843-r0 | ALPINE-CVE-2026-73070 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-73070 |
| Debian:13 | vim | no fix listed | DEBIAN-CVE-2026-73070 |
| Debian:14 | vim | 2:9.2.0858-1 | DEBIAN-CVE-2026-73070 |
| Ubuntu:22.04:LTS | vim | no fix listed | UBUNTU-CVE-2026-73070 |
| Ubuntu:24.04:LTS | vim | no fix listed | UBUNTU-CVE-2026-73070 |
| Ubuntu:26.04:LTS | vim | no fix listed | UBUNTU-CVE-2026-73070 |
Affected products (as reported)
Weakness: CWE-121 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/vim/vim/security/advisories/GHSA-49m8-wwxj-mr69 x_refsource_CONFIRM
- https://github.com/vim/vim/commit/5598618b2daf8e36b3bf0251caaefcf0bf8e85e4 x_refsource_MISC
- https://github.com/vim/vim/releases/tag/v9.2.0842 x_refsource_MISC