Vulnerability · Published Aug 11, 2026 · Assigned by GitHub_M

CVE-2026-73066Tesseract: Heap out-of-bounds write in LSTM Convolve layer via crafted .traineddata

Medium 6.8

In plain English

A medium-severity out-of-bounds write in tesseract from tesseract-ocr. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.8Medium
Exploit odds (30 days)0.1%top 97.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Tesseract is an open source OCR engine. Prior to 5.5.3, a crafted .traineddata LSTM model component loaded through Tesseract's deserializer can cause an unchecked signed integer multiplication in Convolve::DeSerialize in src/lstm/convolve.cpp to wrap the convolution output-channel count, undersizing the forward-pass output buffer while writes use the unwrapped element count and causing a heap out-of-bounds write during OCR recognition. This issue is fixed in version 5.5.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tesseract4.1.1-3.el8_10ALSA-2026:67832
AlmaLinux:9tesseract4.1.1-8.el9_8ALSA-2026:67831
AlmaLinux:8tesseract-devel4.1.1-3.el8_10ALSA-2026:67832
AlmaLinux:9tesseract-devel4.1.1-8.el9_8ALSA-2026:67831
Debian:12tesseractno fix listedDEBIAN-CVE-2026-73066
Debian:13tesseractno fix listedDEBIAN-CVE-2026-73066
Debian:14tesseractno fix listedDEBIAN-CVE-2026-73066
Rocky Linux:10tesseract0:5.3.4-7.el10_2RLSA-2026:67830
Rocky Linux:8tesseract0:4.1.1-3.el8_10RLSA-2026:67832
Rocky Linux:9tesseract0:4.1.1-8.el9_8RLSA-2026:67831
Ubuntu:26.10tesseractno fix listedUBUNTU-CVE-2026-73066

Affected products (as reported)

VendorProductVersions
tesseract-ocr tesseract < 5.5.3

Weakness: CWE-787 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

References