Vulnerability · Published Aug 10, 2026 · Assigned by GitHub_M

CVE-2026-72913Kitty: Command injection into the child shell via chained @kitty-echo + @kitty-ssh DCS escape sequences

High 7.3

In plain English

A high-severity command injection in kitty from kovidgoyal. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.3High
Exploit odds (30 days)0.2%top 89.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Kitty is a cross-platform GPU based terminal. Prior to 0.48.2, the @kitty-echo and @kitty-ssh DCS handlers in kitty/window.py write unauthenticated data to the child shell's stdin, where handle_remote_echo accepts printable shell command characters and handle_remote_ssh calls get_ssh_data in kittens/ssh/utils.py, which emits a newline; chaining the handlers can execute attacker-controlled commands when a user displays untrusted terminal data. This issue is fixed in version 0.48.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12kittyno fix listedDEBIAN-CVE-2026-72913
Debian:13kittyno fix listedDEBIAN-CVE-2026-72913
Debian:14kitty0.48.2-1DEBIAN-CVE-2026-72913
Ubuntu:26.10kittyno fix listedUBUNTU-CVE-2026-72913

Affected products (as reported)

VendorProductVersions
kovidgoyal kitty < 0.48.2

Weakness: CWE-77, CWE-93, CWE-150 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References