Vulnerability · Published Aug 10, 2026 · Assigned by GitHub_M

CVE-2026-72729Discourse: Stored XSS in discourse-local-dates plugin

Low 2.0

In plain English

A low-severity cross-site scripting in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities).

Severity (CVSS 4.0)2.0Low
Exploit odds (30 days)0.5%top 58.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, the discourse-local-dates plugin rendered crafted local-date format data as HTML on sites with a modified or disabled default Content Security Policy. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.

Affected products (as reported)

VendorProductVersions
discourse discourse < 2026.1.6>= 2026.5.0-latest, < 2026.5.2>= 2026.6.0-latest, < 2026.6.1

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References