Vulnerability · Published Aug 7, 2026 · Assigned by GitHub_M
CVE-2026-71852pypdf: Possible long runtimes/large memory usage for large CID font width ranges
Medium 4.8
In plain English
A medium-severity security flaw in pypdf from py-pdf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pypdf is a free and open-source pure-python PDF library. Prior to 6.15.0, a crafted PDF can cause long runtimes and large memory consumption when pypdf/_font.py function Font._collect_cid_character_widths expands unusually large CID font /W width ranges or excessive width entries during text extraction. This issue is fixed in 6.15.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | pypdf | no fix listed | DEBIAN-CVE-2026-71852 |
| Debian:13 | pypdf | no fix listed | DEBIAN-CVE-2026-71852 |
| Debian:14 | pypdf | 6.19.0-1 | DEBIAN-CVE-2026-71852 |
| Debian:12 | pypdf2 | no fix listed | DEBIAN-CVE-2026-71852 |
| PyPI | pypdf | 6.15.0 | PYSEC-2026-3656 |
| PyPI | pypdf | 6.15.0 | GHSA-fwg2-594c-jp42 |
| Ubuntu:24.04:LTS | pypdf | no fix listed | UBUNTU-CVE-2026-71852 |
| Ubuntu:26.04:LTS | pypdf | no fix listed | UBUNTU-CVE-2026-71852 |
| Ubuntu:26.10 | pypdf | no fix listed | UBUNTU-CVE-2026-71852 |
Affected products (as reported)
Weakness: CWE-834 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-fwg2-594c-jp42 x_refsource_CONFIRM
- https://github.com/py-pdf/pypdf/pull/3946 x_refsource_MISC
- https://github.com/py-pdf/pypdf/commit/51cb6acf9e8a35b77e90b4d87d28fe3e1416d7d7 x_refsource_MISC
- https://github.com/py-pdf/pypdf/releases/tag/6.15.0 x_refsource_MISC