Vulnerability · Published Sep 18, 2026 · Assigned by GitHub_M

CVE-2026-71537Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade)

Medium 6.5

In plain English

A medium-severity race condition in Paymenter from Paymenter. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.3%top 74.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit->increment('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed in version 1.5.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistpaymenter/paymenter1.5.7GHSA-5gmm-hjfj-8ff7

Affected products (as reported)

VendorProductVersions
Paymenter Paymenter < 1.5.7

Weakness: CWE-362 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

References