Vulnerability · Published Aug 17, 2026 · Assigned by GitHub_M

CVE-2026-71486vLLM: Derender endpoints decode caller-supplied GenerateResponse token IDs without output bounds

Medium 4.3

In plain English

A medium-severity uncontrolled resource consumption in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.4%top 68.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. Prior to 0.26.0, the /v1/completions/derender and /v1/chat/completions/derender endpoints accept caller-supplied GenerateResponse objects whose generate_responses, choices, token_ids, prompt_logprobs, logprobs.content, top_logprobs, and routed_experts structures are processed by OnlineDerenderer and tokenizer.decode before max_model_len, max_tokens, max_num_seqs, or response-size limits are enforced, allowing an authenticated API client to consume excessive CPU and memory and produce oversized responses. This issue is fixed in version 0.26.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.26.0GHSA-8737-qx52-hjff
PyPIvllm0.26.0PYSEC-2026-3936

Affected products (as reported)

VendorProductVersions
vllm-project vllm < 0.26.0

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

References