Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M

CVE-2026-71438Mermaid configuration APIs allow prototype pollution

Low 2.4

In plain English

A low-severity prototype pollution in mermaid from mermaid-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.4Low
Exploit odds (30 days)0.4%top 70.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14node-mermaidno fix listedDEBIAN-CVE-2026-71438
Ubuntu:22.04:LTSnode-mermaidno fix listedUBUNTU-CVE-2026-71438
Ubuntu:26.10node-mermaidno fix listedUBUNTU-CVE-2026-71438
npmmermaid11.16.1GHSA-c4c3-pg64-4m4v
npmmermaid10.9.8GHSA-c4c3-pg64-4m4v

Affected products (as reported)

VendorProductVersions
mermaid-js mermaid < 10.9.8>= 11.0.0-alpha.1, < 11.16.1

Weakness: CWE-1321 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H

References