Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-70654libvips: A well-crafted PPM image processed via a custom source could lead to possible heap buffer write overflow

Medium 5.8

In plain English

A medium-severity heap buffer overflow in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.8Medium
Exploit odds (30 days)0.1%top 98.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vipsno fix listedDEBIAN-CVE-2026-70654
Debian:13vips8.16.1-1+deb13u2DEBIAN-CVE-2026-70654
Debian:14vips8.18.3-1DEBIAN-CVE-2026-70654

Affected products (as reported)

VendorProductVersions
libvips libvips < 8.18.3

Weakness: CWE-122 · Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N

References