Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-70653libvips: Possible heap-based buffer read overflow when decoding a well-crafted RLE Radiance image

Medium 4.8

In plain English

A medium-severity heap buffer overflow in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.8Medium
Exploit odds (30 days)0.1%top 97.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, the old-style Radiance RLE decoder in libvips/foreign/radiance.c can process a repeat marker at the beginning of a scanline in scanline_read_old and read q[-1] before any prior pixel exists. A crafted Radiance image loaded through VipsForeignLoadRad can therefore disclose four bytes of adjacent heap data, most likely other image data. This issue is fixed in version 8.18.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vipsno fix listedDEBIAN-CVE-2026-70653
Debian:13vips8.16.1-1+deb13u2DEBIAN-CVE-2026-70653
Debian:14vips8.18.3-1DEBIAN-CVE-2026-70653

Affected products (as reported)

VendorProductVersions
libvips libvips < 8.18.3

Weakness: CWE-122 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References