Vulnerability · Published Aug 20, 2026 · Assigned by GitHub_M

CVE-2026-70652libvips: Possible heap-based buffer read overflow when resizing and re-encoding a JPEG with gain map

Low 2.0

In plain English

A low-severity security flaw in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.0Low
Exploit odds (30 days)0.1%top 96.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14vips8.18.3-1DEBIAN-CVE-2026-70652

Affected products (as reported)

VendorProductVersions
libvips libvips < 8.18.3

Weakness: CWE-126 · Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N

References