Vulnerability · Published Aug 3, 2026 · Assigned by GitHub_M

CVE-2026-69249python-cryptography: Duplicate self-signed intermediates can cause exponential path-building

High 8.7

In plain English

A high-severity uncontrolled resource consumption in cryptography from pyca. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.3%top 82.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

python-cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 42.0.0 through 48.0.0, when resolving invalid certificate chains that include duplicate copies of self-signed certificates, the processing recursively invokes the same candidate, leading to an exponential blowup. Although the limitation that the chain depth cannot exceed a specified maximum depth prevents unbounded recursion and guarantees termination, an attacker-controlled certificate chain can lead the processing to easily take more than 5s to reject in testing. This amplification could form the basis for a resource exhaustion denial of service attack. The core issue arises in the recursive nature of build_chain_inner, which does not de-duplicate against previously analyzed candidates. As the correctness of validation is not affected, the integrity of a system cannot be compromised through this vector, only its availability. This issue is fixed in 49.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10python3-cryptography43.0.0-4.el10_2.5ALSA-2026:71658
AlmaLinux:10python3.14-cryptography45.0.4-4.el10_2.5ALSA-2026:64795
AlmaLinux:9python3.14-cryptography45.0.4-4.el9_8.6ALSA-2026:64774
Debian:12python-cryptographyno fix listedDEBIAN-CVE-2026-69249
Debian:13python-cryptographyno fix listedDEBIAN-CVE-2026-69249
Debian:14python-cryptography49.0.0-1DEBIAN-CVE-2026-69249
PyPIcryptography49.0.0PYSEC-2026-3553
PyPIcryptography49.0.0GHSA-jwv3-5hgf-82ww
Rocky Linux:10python-cryptography0:43.0.0-4.el10_2.5RLSA-2026:71658
Rocky Linux:10python3.14-cryptography0:45.0.4-4.el10_2.5RLSA-2026:64795
Rocky Linux:9python3.14-cryptography0:45.0.4-4.el9_8.6RLSA-2026:64774
Ubuntu:26.04:LTSpython-cryptography46.0.5-1ubuntu2.2UBUNTU-CVE-2026-69249
Ubuntu:26.04:LTSpython-cryptography46.0.5-1ubuntu2.2USN-8776-1

Affected products (as reported)

VendorProductVersions
pyca cryptography >= 42.0.0, < 49.0.0

Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References