Vulnerability · Published Aug 18, 2026 · Assigned by GitHub_M

CVE-2026-69220RabbitMQ Java client ValueReader: Unbounded recursive table/array nesting causes StackOverflowError DoS

High 8.7

In plain English

A high-severity security flaw in rabbitmq-java-client from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.7%top 45.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.1, src/main/java/com/rabbitmq/client/impl/ValueReader.java permits ValueReader.readTable and ValueReader.readArray to call ValueReader.readFieldValue recursively for AMQP table type F and AMQP array type A values without a nesting-depth limit. A malicious AMQP server or network intermediary can send approximately 580 nested table levels in the pre-authentication connection.start frame, fitting within the default 131072-byte frame maximum, to trigger StackOverflowError. The error terminates the client input processing thread and causes denial of service. This issue is fixed in version 5.33.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-java-clientno fix listedDEBIAN-CVE-2026-69220
Debian:13rabbitmq-java-clientno fix listedDEBIAN-CVE-2026-69220
Mavencom.rabbitmq:amqp-client5.33.1GHSA-93j5-89vc-pph4
Ubuntu:22.04:LTSrabbitmq-java-clientno fix listedUBUNTU-CVE-2026-69220
Ubuntu:24.04:LTSrabbitmq-java-clientno fix listedUBUNTU-CVE-2026-69220
Ubuntu:26.04:LTSrabbitmq-java-clientno fix listedUBUNTU-CVE-2026-69220
Ubuntu:26.10rabbitmq-java-clientno fix listedUBUNTU-CVE-2026-69220

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-java-client < 5.33.1

Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References