Vulnerability · Published Aug 25, 2026 · Assigned by GitHub_M

CVE-2026-68515OpenEXR: Heap out-of-bounds write in exrmultiview with subsampled channel union

High 7.1

In plain English

A high-severity heap buffer overflow in openexr from AcademySoftwareFoundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.2%top 91.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions before 3.2.11, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13, exrmultiview can write past a heap allocation when it combines two attacker-supplied, individually valid scanline EXR files whose union dataWindow is not aligned to one view's channel subsampling. The utility allocates sampled channel storage using a truncated union_width / xSampling, then reads the sampled input through a Slice based on the misaligned union window, producing a heap out-of-bounds write. The trigger is normal public-tool processing, such as exrmultiview left A.exr right B.exr out.exr with crafted but valid inputs, so this is not solely an API or caller-precondition issue. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8OpenEXR-devel2.2.0-12.el8_10.3ALSA-2026:82345
AlmaLinux:8OpenEXR-libs2.2.0-12.el8_10.3ALSA-2026:82345
AlmaLinux:10openexr3.1.10-8.el10_2.4ALSA-2026:69609
AlmaLinux:9openexr3.1.1-3.el9_8.4ALSA-2026:69608
AlmaLinux:10openexr-devel3.1.10-8.el10_2.4ALSA-2026:69609
AlmaLinux:9openexr-devel3.1.1-3.el9_8.4ALSA-2026:69608
AlmaLinux:10openexr-libs3.1.10-8.el10_2.4ALSA-2026:69609
AlmaLinux:9openexr-libs3.1.1-3.el9_8.4ALSA-2026:69608
Debian:12openexrno fix listedDEBIAN-CVE-2026-68515
Debian:13openexrno fix listedDEBIAN-CVE-2026-68515
Debian:14openexr3.4.14-0.1DEBIAN-CVE-2026-68515
Rocky Linux:8OpenEXR0:2.2.0-12.el8_10.3RLSA-2026:82345
Rocky Linux:10openexr0:3.1.10-8.el10_2.4RLSA-2026:69609
Rocky Linux:9openexr0:3.1.1-3.el9_8.4RLSA-2026:69608
Ubuntu:26.10openexrno fix listedUBUNTU-CVE-2026-68515

Affected products (as reported)

VendorProductVersions
AcademySoftwareFoundation openexr >= 3.3.0, < 3.3.13>= 3.4.0, < 3.4.14< 3.2.11

Weakness: CWE-122, CWE-787 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H

References