Vulnerability · Published Aug 5, 2026 · Assigned by apache
CVE-2026-67590Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow
High 7.5
In plain English
A high-severity security flaw in Apache Qpid ProtonJ2 from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | qpid-proton | no fix listed | DEBIAN-CVE-2026-67590 |
| Debian:13 | qpid-proton | no fix listed | DEBIAN-CVE-2026-67590 |
| Debian:14 | qpid-proton | no fix listed | DEBIAN-CVE-2026-67590 |
| Ubuntu:22.04:LTS | qpid-proton | no fix listed | UBUNTU-CVE-2026-67590 |
| Ubuntu:24.04:LTS | qpid-proton | no fix listed | UBUNTU-CVE-2026-67590 |
| Ubuntu:26.04:LTS | qpid-proton | no fix listed | UBUNTU-CVE-2026-67590 |
| Ubuntu:26.10 | qpid-proton | no fix listed | UBUNTU-CVE-2026-67590 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Qpid ProtonJ2 | 0 – through 1.1.0 |
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H