Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M

CVE-2026-67434PHP_CodeSniffer gitblame report command injection via crafted filename

High 7.3

In plain English

A high-severity OS command injection in PHP_CodeSniffer from PHPCSStandards. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.3High
Exploit odds (30 days)1.1%top 35.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PHP_CodeSniffer tokenizes PHP files and detects violations of a defined set of coding standards. Prior to versions 3.13.6 and 4.0.2, PHP_CodeSniffer contains a command injection vulnerability in the code that generates the Gitblame, Hgblame, and Svnblame report formats. As a result, running PHP_CodeSniffer over untrusted files, for example in a continuous integration pipeline that scans pull requests, or on a developer machine reviewing third party code, could result in attacker controlled shell commands being executed when the Gitblame, Hgblame, or Svnblame report processes a file whose name contains shell metacharacters. Users using the default Full report, or any of the other non-blame reports, are not affected. Users on a runtime platform which does not allow filenames to contain shell metacharacters, such as " and ;, are not affected. This issue is fixed in versions 3.13.6 and 4.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsquizlabs/php_codesniffer3.13.6GHSA-hmqg-cxww-wqhq
Packagistsquizlabs/php_codesniffer4.0.2GHSA-hmqg-cxww-wqhq

Affected products (as reported)

VendorProductVersions
PHPCSStandards PHP_CodeSniffer < 3.13.6>= 4.0.0, < 4.0.2

Weakness: CWE-78 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References