Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67420RabbitMQ OAuth credential refresh retains revoked runtime tags

Low 2.3

In plain English

A low-severity missing authorization in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.3%top 80.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5, RabbitMQ OAuth credential refresh retains revoked runtime tags. when an existing AMQP connection refreshes from an OAuth token that grants the impersonator tag to a valid same-username token that no longer grants that tag, RabbitMQ updates the OAuth backend implementation (token/scopes/expiry) but leaves the connection's runtime #user.tags unchanged. rabbitaccesscontrol:checkuserid/2 then still honors the stale impersonator tag, so the connection (including newly opened channels) can continue publishing messages with a foreign AMQP userid after that privilege should have been revoked. A fresh connection using the downgraded token correctly refuses the same publish, proving the defect is stale session state rather than the token Limited to connections that once held impersonator and successfully refresh to a downgraded same-username rabbitauthbackendoauth2 (or an equivalent refresh-capable backend that returns tags) is enabled for This issue is fixed in versions 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67420
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67420
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-67420
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67420
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67420
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67420
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67420

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.19>= 4.0.0, < 4.0.24>= 4.1.0, < 4.1.15>= 4.2.0, < 4.2.10>= 4.3.0, < 4.3.5

Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References