Vulnerability · Published Oct 14, 2026 · Assigned by GitHub_M

CVE-2026-67418RabbitMQ MQTT 5: inapplicable PUBLISH property disconnects matching subscribers

Medium 5.3

In plain English

A medium-severity security flaw in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.4%top 65.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5, the MQTT 5 parser in deps/rabbitmq_mqtt/src/rabbit_mqtt_packet.erl accepts Request-Problem-Information on PUBLISH packets even though the property is valid only for CONNECT. An authenticated publisher with topic write permission can cause the broker to store and route that inapplicable property to a separately authenticated matching subscriber. When the subscriber path serializes the outbound PUBLISH, serialise_prop/2 has no matching clause, and the uncontained function_clause exception closes the victim MQTT or Web MQTT connection. The publisher connection and broker remain available, and queued replay, retained-message persistence, and broker-wide denial of service were not established. This issue is fixed in versions 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67418
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67418
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-67418
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67418
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67418
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67418
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67418

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.19>= 4.0.0, < 4.0.24>= 4.1.0, < 4.1.15>= 4.2.0, < 4.2.10>= 4.3.0, < 4.3.5

Weakness: CWE-1286, CWE-248 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References