Vulnerability · Published Oct 14, 2026 · Assigned by GitHub_M
CVE-2026-67416RabbitMQ: AMQP 1.0 symbolic body descriptor prefix collisions bypass validation
Medium 5.3
In plain English
A medium-severity improper input validation in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.24, 4.1.15, 4.2.10, and 4.3.4, the optimized AMQP 1.0 server_mode parser in deps/amqp10_common/src/amqp10_binary_parser.erl matches the textual prefixes of symbolic data, sequence, and value body descriptors without verifying their encoded symbol lengths. An authenticated AMQP 1.0 publisher with write permission can submit a well-formed unknown descriptor that begins with a registered body descriptor, and RabbitMQ misclassifies and stores the bytes as a standard body section. Strict AMQP 1.0 consumers can terminate while decoding the stored entry. For bodies misclassified as data, AMQP 0-9-1 or other cross-protocol conversion performs full body decoding and can terminate the consumer protocol process, with acknowledgement-required delivery permitting repeated failures. Sequence and value classifications are normally transported as opaque encoded payloads on that conversion path. The broker remains alive, and the issue does not bypass routing or authorization. This issue is fixed in versions 4.0.24, 4.1.15, 4.2.10, and 4.3.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67416 |
| Debian:13 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67416 |
| Debian:14 | rabbitmq-server | 4.3.6-1 | DEBIAN-CVE-2026-67416 |
| Ubuntu:22.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67416 |
| Ubuntu:24.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67416 |
| Ubuntu:26.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67416 |
| Ubuntu:26.10 | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67416 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 4.0.0, < 4.0.24>= 4.1.0, < 4.1.15>= 4.2.0, < 4.2.10>= 4.3.0, < 4.3.4 |
Weakness: CWE-20, CWE-248, CWE-754 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-p35w-6mx2-q4pc x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/pull/17017 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/pull/17287 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/commit/c9b4b10c2dbf0f1c89f10b482ac8b45f84dc5954 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/commit/d5186e66e056960f58e2d0fbee2fcc66e1ed6fb9 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.4 x_refsource_MISC