Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M
CVE-2026-67410RabbitMQ: OAuth2 Client Secret Exposed via Unauthenticated JavaScript Endpoint
High 8.2
In plain English
A high-severity information exposure in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.3.3 and 4.2.9, OAuth2 Client Secret Exposed via Unauthenticated JavaScript Endpoint (CWE-200). when OAuth2 authentication is enabled for the RabbitMQ Management UI and the configured flow, IDP use a client secret, the oauthclientsecret configuration value is included in the JavaScript served by the unauthenticated endpoint /js/oidc-oauth/bootstrap.js. Any user who can reach the management UI port can retrieve the OAuth2 client secret without Files: deps/rabbitmqmanagement/src/rabbitmgmtwmauth.erl, line 186 deps/rabbitmqmanagement/src/rabbitmgmtoauthbootstrap.erl, lines 35-50 deps/rabbitmqmanagement/src/rabbitmgmtdispatcher.erl, lines 45-49 (route registration) Code Path: 1. The route /js/oidc-oauth/bootstrap.js is registered as a plain Cowboy handler (rabbitmgmtdispatcher.erl:46): Credential exposure for the affected configuration: OAuth2 client secret is accessible without any authentication Token theft: Attacker can complete the authorization code flow using stolen authorization codes Client impersonation: Attacker can make requests. Any RabbitMQ deployment with: This issue is fixed in versions 4.3.3 and 4.2.9.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | rabbitmq-server | 4.3.6-1 | DEBIAN-CVE-2026-67410 |
| Ubuntu:22.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67410 |
| Ubuntu:24.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67410 |
| Ubuntu:26.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67410 |
| Ubuntu:26.10 | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67410 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 4.3.0, < 4.3.3>= 4.2.0, < 4.2.9 |
Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-f9f2-q3jf-wfj3 x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/commit/60a85d3605ebf94fd234497242812547d441d457 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/commit/869f800998334bb363f2ad046f58de9caedc409e x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3 x_refsource_MISC