Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67406RabbitMQ: Federation and Shovel Gen-Servers Lack format_status Callback — Plaintext Credentials Exposed in Crash Dumps and sys:get_status

Medium 4.6

In plain English

A medium-severity information exposure in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.6Medium
Exploit odds (30 days)0.3%top 72.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.3.3, 4.2.9, 4.1.14, and 4.0.23, Shovel does not format state logged by the crash reporter and can leave unencrypted credentials in a crash dump file. the shovel worker genserver processes does not implement the formatstatus/2 callback. When these processes crash (e.g., due to network partitions, connection failures), the OTP SASL error handler writes the full process state , including plaintext AMQP passwords and URIs , to the error log. This is particularly severe for the shovel worker, which stores deobfuscated plaintext URIs (including amqp://user:password@host format) in its genserver state for the entire process Automatic Credential Exposure: Shovel worker crashes (common during network partitions) automatically write plaintext upstream/downstream passwords to error logs No Special Configuration Needed: Unlike DEBUG logging, SASL error reports are always active Broad. This issue is fixed in versions 4.3.3, 4.2.9, 4.1.14, and 4.0.23.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67406
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67406
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-67406
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67406
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67406
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67406
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67406

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.3.0, < 4.3.3>= 4.2.0, < 4.2.9>= 4.1.0, < 4.1.14>= 4.0.0, < 4.0.23

Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References