Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M
CVE-2026-67404RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch
Critical 9.2
In plain English
A critical-severity improper certificate validation in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67404 |
| Debian:13 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67404 |
| Debian:14 | rabbitmq-server | 4.3.0-2 | DEBIAN-CVE-2026-67404 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | UBUNTU-CVE-2026-67404 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | UBUNTU-CVE-2026-67404 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | USN-8933-1 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | UBUNTU-CVE-2026-67404 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6 |
Weakness: CWE-295 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-37wx-r6q9-6fhj x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 x_refsource_MISC