Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-67238RabbitMQ: Atom-table exhaustion via reply-to queue name decoding

High 7.1

In plain English

A high-severity uncontrolled resource consumption in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.4%top 67.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, rabbit_pid_codec:decompose_from_binary/1 parses a caller-supplied ETF-encoded binary and calls binary_to_atom(Node, utf8) on the node-name field. It is reached from rabbit_volatile_queue:pid_from_name/2, which is invoked for any queue name / routing key beginning amq.rabbitmq.reply-to.. The CandidateNodes membership check happens after the atom is created, and the surrounding try/catch cannot reclaim atoms (they are never GC'd). binary_to_existing_atom is not used. Any authenticated AMQP client can crash the entire Erlang VM (all vhosts, all connections) with ~1M cheap requests. Preconditions include Authenticated AMQP 0-9-1 connection to any vhost No per-connection rate limit low enough to make ~1M operations infeasible. This issue is fixed in versions 4.2.7 and 4.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14rabbitmq-server4.3.2-1DEBIAN-CVE-2026-67238
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6USN-8933-1
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6UBUNTU-CVE-2026-67238
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7UBUNTU-CVE-2026-67238
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7USN-8933-1
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2USN-8933-1
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2UBUNTU-CVE-2026-67238

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.7>= 4.3.0, < 4.3.1

Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References