Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M
CVE-2026-67232RabbitMQ: Web-MQTT decompression bomb
High 8.2
In plain English
A high-severity security flaw in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The cowboy WebSocket options at line 117 set compress => true, enabling RFC 7692 permessage-deflate negotiation. The handler does not set max_frame_size, so cowboy's default of infinity applies. cowlib's cow_ws:parse_payload/9 calls zlib:inflate/2 on the compressed payload with no output-size limit. An attacker can negotiate permessage-deflate during the WebSocket upgrade and send a frame containing a zlib bomb (e.g. 50 KB → 5 GB). Decompression occurs in the connection process before websocket_handle/2 ever sees the MQTT bytes. An unauthenticated attacker can crash a RabbitMQ node running the Web-MQTT plugin by sending a single highly-compressed WebSocket frame (a few KB on the wire) that inflates to gigabytes in memory. The cowboy WebSocket handler decompresses the entire frame before the MQTT CONNECT packet is processed, so no credentials are required. Preconditions include rabbitmq_web_mqtt plugin enabled (not default, but common for browser clients) Network reachability to port 15675/15676 No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67232 |
| Debian:13 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67232 |
| Debian:14 | rabbitmq-server | 4.3.0-2 | DEBIAN-CVE-2026-67232 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | UBUNTU-CVE-2026-67232 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | UBUNTU-CVE-2026-67232 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | USN-8933-1 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | UBUNTU-CVE-2026-67232 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6 |
Weakness: CWE-409 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-gmgx-hhg5-43gr x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.0 x_refsource_MISC