Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67230RabbitMQ: Web-STOMP unbounded pre-auth accumulation

Medium 6.3

In plain English

A medium-severity resource allocation without limits in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.6%top 52.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15, 4.0.20, 4.1.11, and 4.2.6, the Web STOMP WebSocket handler enforced neither max_frame_size nor login_timeout before authentication, allowing an unauthenticated client to keep a connection alive with a slow stream of small frames and accumulate unbounded pre-authentication state. The rabbitmq_web_stomp plugin must be enabled, and no authentication is required to reach the vulnerable path. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67230
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67230
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-67230
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67230
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67230
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67230

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.6>= 4.1.0, < 4.1.11>= 4.0.0, < 4.0.20>= 3.13.0, < 3.13.15

Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References