Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67227RabbitMQ: Atom exhaustion: to_atom on global-parameter :name

Medium 5.9

In plain English

A medium-severity uncontrolled resource consumption in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.9Medium
Exploit odds (30 days)0.4%top 68.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1, Atom exhaustion: toatom on global-parameter :name. resourceexists/2 (and the PUT/DELETE handlers) call rabbitdatacoercion:toatom/1 on the :name URL path segment. toatom/1 uses binarytoatom/2 (unsafe). The endpoint requires policymaker (not management, but below A user with the policymaker tag can crash the node by exhausting the atom table via repeated requests to /api/global-parameters/:name with unique :name Management plugin enabled policymaker tag ~1M HTTP. This issue is fixed in versions 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67227
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67227
Debian:14rabbitmq-server4.3.2-1DEBIAN-CVE-2026-67227
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67227
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67227
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67227

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.0.0, < 4.0.22>= 4.1.0, < 4.1.14>= 4.2.0, < 4.2.7>= 4.3.0, < 4.3.1

Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References