Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-67224RabbitMQ: Admin path-traversal write via trace name

Low 2.1

In plain English

A low-severity path traversal in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.1Low
Exploit odds (30 days)0.4%top 70.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1, The trace consumer constructs the output path as filename:join(TraceDir, Name ++ ".log") where Name comes from PUT /api/traces/:vhost/:name. No safe_relative_path / traversal check is applied on the write side, while the read side (rabbit_tracing_files.erl) does call rabbit_misc:safe_relative_path/1 , proving the omission is an oversight, not design. The .log suffix is forced and the endpoint requires administrator. A user with the administrator tag can write a .log-suffixed file to an arbitrary filesystem path writable by the rabbitmq user via the tracing plugin's name parameter, e.g. /etc/cron.d/x.log (if writable) or overwrite existing .log files outside the trace directory. Preconditions include rabbitmq_tracing plugin enabled administrator tag Target path writable by rabbitmq OS user. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67224
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67224
Debian:14rabbitmq-server4.3.2-1DEBIAN-CVE-2026-67224
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67224
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67224
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67224

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6>= 4.3.0, < 4.3.1

Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References