Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67222RabbitMQ: list_to_atom on auth_mechanism URI tokens in amqp_client

Medium 5.9

In plain English

A medium-severity uncontrolled resource consumption in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.9Medium
Exploit odds (30 days)0.3%top 75.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15, 4.0.20, 4.1.11, and 4.2.6, mechanisms/1 applied list_to_atom/1 to every colon-delimited token in an attacker-controlled auth_mechanism value, permanently consuming Erlang VM atoms and allowing the node to be crashed with a large request. Exploitation requires the Shovel or Federation plugin to be in use, and setting auth_mechanism requires the policymaker tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67222
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67222
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-67222
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67222
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67222
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67222

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6

Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References