Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-67221RabbitMQ: AMQP 1.0 shovel status exposes plaintext URI passwords

Medium 5.9

In plain English

A medium-severity security flaw in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.9Medium
Exploit odds (30 days)0.2%top 91.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The AMQP 0-9-1 shovel calls amqp_uri:remove_credentials before storing its connection URI, but the AMQP 1.0 shovel stores the raw URI including the password. The stored URI is visible via GET /api/shovels and via rabbitmqctl shovel_status. Preconditions include The Shovel plugin must be in use with AMQP 1.0 shovels configured using URI-embedded credentials. Reading the exposed status requires the monitoring tag.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67221
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67221
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-67221
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67221
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67221
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67221

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6

Weakness: CWE-312 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References