Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-67218RabbitMQ: Super-stream HTTP creation skips configure-permission check

Low 2.1

In plain English

A low-severity missing authorization in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.1Low
Exploit odds (30 days)0.4%top 68.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 4.0.22, 4.1.11, 4.2.6, and 4.3.0, accept_content/2 at line 56 calls rabbit_stream_manager:create_super_stream/... directly after is_authorized (which only checks the management tag + vhost access via is_authorized_vhost). The stream-protocol equivalent (rabbit_stream_reader.erl create_super_stream handler) calls rabbit_stream_utils:check_super_stream_management_permitted/4 which enforces configure on the exchange and each partition queue. The HTTP handler omits this call entirely. A user with management tag and vhost access , but no configure permission on any resource , can create super-streams (an exchange + N partition stream queues + bindings) via the HTTP API. The native stream-protocol path enforces configure on each resource; the HTTP path does not, creating a privilege escalation from 'can view' to 'can create persistent cluster-wide resources.' Preconditions include rabbitmq_stream_management plugin enabled management tag + vhost access (no resource permissions needed). This issue is fixed in versions 4.0.22, 4.1.11, 4.2.6, and 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67218
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-67218
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67218
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67218
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67218

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.0.0, < 4.0.22>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6

Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References