Vulnerability · Published Aug 25, 2026 · Assigned by apache

CVE-2026-66422Apache Tomcat: Servlet role references can bypass declarative role constraints

High 8.1

In plain English

A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 62.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-66422
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-66422
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-66422
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-66422
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-66422
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-66422
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-66422
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-66422
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-66422
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-66422
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-66422
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-66422
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-66422
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-66422
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-66422
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-66422

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2410.1.0-M1 – through 10.1.579.0.25 – through 9.0.1208.5.46 – through 8.5.1007.0.97 – through 7.0.109

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

References