Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-66079RabbitMQ: Pre-auth AMQP 1.0 array32 zero-width element DoS

High 8.2

In plain English

A high-severity resource allocation without limits in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 75.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6, parse_array_primitive/2 for constructor 0x45 (list0) returns an element with byte-width B = 0. The enclosing array32 parser at line 148 reads a 4-byte Count from the wire and loops Count times consuming B bytes each , with B = 0, no input is consumed and the loop builds a list of Count empty elements bounded only by the 32-bit field. The SASL-mechanisms / SASL-init frame is parsed by amqp10_framing:decode_bin/1 from rabbit_amqp_reader.erl:412 before authentication completes. The pre-auth incoming_max_frame_size (default 8192 bytes) caps the frame, not the Count field, so a 19-byte payload with Count = 0xFFFFFFFF is accepted. No max_heap_size is set on the reader process. An unauthenticated network attacker can crash any RabbitMQ node that has the AMQP 1.0 listener enabled (default port 5672) by sending a single ~19-byte frame. The reader process attempts to build a list of ~4 billion empty elements, exhausting heap memory and terminating the Erlang VM. All tenants and protocols on the node lose service. Preconditions include Network reachability to the AMQP listener (port 5672, enabled by default) No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-66079
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-66079
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-66079
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6UBUNTU-CVE-2026-66079
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6USN-8933-1
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7USN-8933-1
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7UBUNTU-CVE-2026-66079
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2USN-8933-1
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2UBUNTU-CVE-2026-66079

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6

Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References