Vulnerability · Published Aug 17, 2026 · Assigned by GitHub_M

CVE-2026-65974ERPNext: Server-Side Template Injection leading to Remote Code Execution

Critical 9.9

In plain English

A critical-severity security flaw in erpnext from frappe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities).

Severity (CVSS 3.1)9.9Critical
Exploit odds (30 days)1.0%top 36.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.111.0 and 16.22.0, limited authenticated users can cross a permission boundary in Frappe safe execution because frappe.render_template is exposed without forcing restrict_globals, allowing server-side template injection and remote code execution. This issue is fixed in versions 15.111.0 and 16.22.0.

Affected products (as reported)

VendorProductVersions
frappe erpnext < 15.111.0>= 16.0.0, < 16.22.0

Weakness: CWE-1336 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References