Vulnerability · Published May 14, 2026 · Assigned by PostgreSQL

CVE-2026-6575PostgreSQL pg_restore_attribute_stats accepts values that cause query planning to read past end of stats array

Medium 4.3

In plain English

A medium-severity security flaw in PostgreSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.2%top 89.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Buffer over-read in PostgreSQL function pg_restore_attribute_stats() accepts array values of unmatched length, which causes query planning to read past end of one array. This allows a table maintainer to infer memory values past that array end. Within major version 18, minor versions before PostgreSQL 18.4 are affected. Versions before PostgreSQL 18 are unaffected.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9pg_repack1.5.3-1.module_el9.8.0+234+5456f35dALSA-2026:26204
AlmaLinux:9pgaudit18.0-1.module_el9.8.0+234+5456f35dALSA-2026:26204
AlmaLinux:9pgvector0.8.1-1.module_el9.8.0+234+5456f35dALSA-2026:26204
AlmaLinux:9postgis3.6.1-2.module_el9.8.0+239+6fb51d38ALSA-2026:26204
AlmaLinux:9postgis-client3.6.1-2.module_el9.8.0+239+6fb51d38ALSA-2026:26204
AlmaLinux:9postgis-docs3.6.1-2.module_el9.8.0+239+6fb51d38ALSA-2026:26204
AlmaLinux:9postgis-upgrade3.6.1-2.module_el9.8.0+239+6fb51d38ALSA-2026:26204
AlmaLinux:9postgis-utils3.6.1-2.module_el9.8.0+239+6fb51d38ALSA-2026:26204
AlmaLinux:9postgres-decoderbufs3.3.1-1.Final.module_el9.8.0+234+5456f35dALSA-2026:26204
AlmaLinux:9postgresql18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-contrib18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-docs18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-plperl18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-plpython318.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-pltcl18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-private-devel18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-private-libs18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-server18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-server-devel18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-static18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-test18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-test-rpm-macros18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-upgrade18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:9postgresql-upgrade-devel18.4-2.module_el9.8.0+280+5ad12178ALSA-2026:26204
AlmaLinux:10postgresql1818.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-contrib18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-docs18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-plperl18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-plpython318.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-private-devel18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-private-libs18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-server18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-server-devel18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-static18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-test18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-test-rpm-macros18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-upgrade18.4-1.el10_2ALSA-2026:27742
AlmaLinux:10postgresql18-upgrade-devel18.4-1.el10_2ALSA-2026:27742
Alpine:v3.23postgresql1818.4-r0ALPINE-CVE-2026-6575
Alpine:v3.24postgresql1818.4-r0ALPINE-CVE-2026-6575
Debian:14postgresql-1818.4-1DEBIAN-CVE-2026-6575
Ubuntu:22.04:LTSpostgresql-1414.23-0ubuntu0.22.04.1UBUNTU-CVE-2026-6575
Ubuntu:24.04:LTSpostgresql-1616.14-0ubuntu0.24.04.1UBUNTU-CVE-2026-6575
Ubuntu:25.10postgresql-1717.10-0ubuntu0.25.10.1UBUNTU-CVE-2026-6575
Ubuntu:26.04:LTSpostgresql-1818.4-0ubuntu0.26.04.1UBUNTU-CVE-2026-6575

Affected products (as reported)

VendorProductVersions
n/a PostgreSQL 18 – before 18.4

Weakness: CWE-126 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References