Vulnerability · Published Aug 25, 2026 · Assigned by apache

CVE-2026-65637Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete

Critical 9.8

In plain English

A critical-severity improper input validation in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.8%top 44.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-admin-webapps1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-admin-webapps1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-docs-webapp1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-docs-webapp1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-el-3.0-api1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-el-3.0-api1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-lib1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-lib1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-webapps1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-webapps1:9.0.121-1.el9_8ALSA-2026:93469
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-65637
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-65637
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-65637
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-65637
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-65637
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-65637
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-65637
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-65637
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.121GHSA-f525-44xv-f2qj
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.59GHSA-f525-44xv-f2qj
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.25GHSA-f525-44xv-f2qj
Mavenorg.apache.tomcat:tomcat-coyote10.1.59GHSA-f525-44xv-f2qj
Mavenorg.apache.tomcat:tomcat-coyote11.0.25GHSA-f525-44xv-f2qj
Mavenorg.apache.tomcat:tomcat-coyote9.0.121GHSA-f525-44xv-f2qj
Rocky Linux:8tomcat1:9.0.121-1.el8_10RLSA-2026:92869
Rocky Linux:9tomcat1:9.0.121-1.el9_8RLSA-2026:93469
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-65637
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-65637
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-65637
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-65637
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-65637
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-65637
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-65637
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-65637

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.20 – through 11.0.2410.1.53 – through 10.1.579.0.115 – through 9.0.120

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References