Vulnerability · Published Sep 9, 2026 · Assigned by apache

CVE-2026-65181Apache Impala: RCE via External Data Source Class Loading

High 8.1

In plain English

A high-severity security flaw in Apache Impala from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 54.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Insufficient authorization of Data Source tables in Impala 2.7-4.5 allows a client with privileges to upload a file to remote storage and create a table to execute arbitrary Java code. Users are recommended to upgrade to version 4.5.2, which fixes this issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Impala 2.7.0 – through 4.5.1

Weakness: CWE-913 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References