Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M

CVE-2026-64677Anki's local HTTP server is vulnerable to directory traversal attacks

Medium 5.9

In plain English

A medium-severity path traversal in anki from ankitects. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities).

Severity (CVSS 4.0)5.9Medium
Exploit odds (30 days)1.0%top 36.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, endpoints in Anki's local HTTP server do not adequately constrain requested media and built-in data paths, allowing scripts served from shared decks, or malicious websites combined with an origin-check bypass, to read local files through directory traversal. This issue is fixed in version 25.09.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSankino fix listedUBUNTU-CVE-2026-64677
Ubuntu:24.04:LTSankino fix listedUBUNTU-CVE-2026-64677

Affected products (as reported)

VendorProductVersions
ankitects anki >= 25.09.3

Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References