Vulnerability · Published Jul 27, 2026 · Assigned by GitHub_M

CVE-2026-64644Next.js: Denial of Service in the Image Optimization API using SVGs

Medium 6.3

In plain English

A medium-severity security flaw in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.3Medium
Exploit odds (30 days)0.7%top 48.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Next.js is a React framework for building full-stack web applications. In versions 15.5.0 through 15.5.20 and 16.0.0 through 16.2.10, when self-hosting Next.js with the default image loader, the Image Optimization API can optimize remotely hosted images if configured (not enabled by default). If those images contain malicious content, they can cause CPU exhaustion in /_next/image endpoints.Only config.images.remotePatterns is affected, and just the patterns in that array, whereas config.images.unoptimized: true, config.images.loader: 'custom', and Vercel are not impacted. This issue has been fixed in versions 15.5.21 and 16.2.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmnext15.5.21GHSA-q8wf-6r8g-63ch
npmnext16.2.11GHSA-q8wf-6r8g-63ch

Affected products (as reported)

VendorProductVersions
vercel next.js >= 15.5.0, < 15.5.21>= 16.0.0, < 16.2.11

Weakness: CWE-407 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References