Vulnerability · Published Jul 27, 2026 · Assigned by GitHub_M

CVE-2026-64641Next.js: Denial of Service in App Router using Server Actions

High 8.2

In plain English

A high-severity security flaw in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.9%top 41.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Next.js is a React framework for building full-stack web applications. In versions 13.0.0 through 15.5.20 and 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive CPU usage blocking processing of further requests in the same process. This issue has been fixed in versions 15.5.21 and 16.2.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmnext15.5.21GHSA-m99w-x7hq-7vfj
npmnext16.2.11GHSA-m99w-x7hq-7vfj

Affected products (as reported)

VendorProductVersions
vercel next.js >= 13.0.0, < 15.5.21>= 16.0.0, < 16.2.11

Weakness: CWE-834 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References