Vulnerability · Published Jul 21, 2026 · Assigned by VulnCheck
CVE-2026-64627Parse Server 9.0.0 Schema Disclosure via GraphQL Variable Coercion
Medium 6.9
In plain English
A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities).
Official description
Parse Server versions >= 9.0.0 before 9.10.0-alpha.4 and versions before 8.6.85 contain a schema disclosure vulnerability. When the GraphQL API is mounted with public introspection disabled (graphQLPublicIntrospection: false, the default), schema-derived 'Did you mean ...?' suggestions were still returned in GraphQL error messages produced during variable coercion, which were not covered by the introspection-hardening control (that only handled validation errors). An unauthenticated caller possessing only the public application id can iteratively recover hidden schema identifiers — including registered Cloud Code function names and Parse class and field names — by submitting queries or mutations whose variables contain near-miss enum values or input-object field names. This is a follow-up bypass of GHSA-8cph-rgr4-g5vj. The issue is fixed in 9.10.0-alpha.4 and 8.6.85.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parse-community | parse-server | 9.0.0 – before 9.10.0-alpha.4 |
| parse-community | parse-server | 0 – before 8.6.85 |
Weakness: CWE-209 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
References
- GitHub Security Advisory (GHSA-9g8f-h8f3-hjcm) vendor-advisory
- VulnCheck Advisory: Parse Server 9.0.0 Schema Disclosure via GraphQL Variable Coercion third-party-advisory