Vulnerability · Published Apr 16, 2026 · Assigned by openjs
CVE-2026-6414@fastify/static vulnerable to route guard bypass via encoded path separators
Medium 5.9
In plain English
A medium-severity security flaw in @fastify/static from @fastify/static. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
@fastify/static versions 8.0.0 through 9.1.0 decode percent-encoded path separators (%2F) before filesystem resolution, while Fastify's router treats them as literal characters. This mismatch allows attackers to bypass route-based middleware or guards that protect files served by @fastify/static. For example, a route guard on a protected path can be circumvented by encoding the path separator in the URL. Upgrade to @fastify/static 9.1.1 to fix this issue. There are no workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @fastify/static | 9.1.1 | GHSA-x428-ghpx-8j92 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| @fastify/static | @fastify/static | 8.0.0 – before 9.1.1 |
Weakness: CWE-177 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N