Vulnerability · Published Aug 18, 2026 · Assigned by GitHub_M

CVE-2026-63632ONNX: Heap-Buffer-Overflow READ in Gemm Version Converter Adapter via Undersized Input Shape

Low 3.3

In plain English

A low-severity out-of-bounds read in onnx from onnx. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.3Low
Exploit odds (30 days)0.2%top 93.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. From 1.3.0 until 1.22.0, onnx.version_converter.convert_version() can perform an out-of-bounds read in Gemm_7_6::adapt_gemm_7_6() in onnx/version_converter/adapters/gemm_7_6.h when a Gemm node has input tensors with fewer than two dimensions because B_shape[1], A_shape[0], or A_shape[1] is accessed without a rank check, potentially causing a process crash during an opset 7 to 6 downgrade. This issue is fixed in version 1.22.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12onnxno fix listedDEBIAN-CVE-2026-63632
Debian:13onnxno fix listedDEBIAN-CVE-2026-63632
Debian:14onnxno fix listedDEBIAN-CVE-2026-63632
PyPIonnx1.22.0PYSEC-2026-3587
PyPIonnx1.22.0GHSA-p893-rvq9-2xf9
Ubuntu:22.04:LTSonnxno fix listedUBUNTU-CVE-2026-63632
Ubuntu:26.04:LTSonnxno fix listedUBUNTU-CVE-2026-63632
Ubuntu:26.10onnxno fix listedUBUNTU-CVE-2026-63632

Affected products (as reported)

VendorProductVersions
onnx onnx >= 1.3.0, < 1.22.0

Weakness: CWE-125 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References