Vulnerability · Published Aug 21, 2026 · Assigned by GitHub_M

CVE-2026-63462Unleash: Unauthenticated single-request DoS via OpenAPI validation error formatter

High 7.5

In plain English

A high-severity security flaw in unleash from Unleash. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 46.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Unleash is an open-source feature management platform. Prior to 7.5.2, 7.6.5, and 8.0.2, the shared OpenAPI validation error path in src/lib/error/bad-data-error.ts passes a raw request value from lodash.get to JSON.stringify in genericErrorMessage and fromOpenApiValidationErrors without guarding stack exhaustion. An unauthenticated attacker can send a roughly 10 KB JSON value nested thousands of levels deep to POST /edge/validate, POST /edge/issue-token, or another OpenAPI-validated endpoint, causing RangeError: Maximum call stack size exceeded in openAPIValidationMiddleware and terminating the Node process because no uncaughtException handler recovers it. Replaying the request can sustain a complete service outage. This issue is fixed in versions 7.5.2, 7.6.5, and 8.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmunleash-server7.5.2GHSA-r5pq-6chh-j3xp
npmunleash-server7.6.5GHSA-r5pq-6chh-j3xp
npmunleash-server8.0.2GHSA-r5pq-6chh-j3xp

Affected products (as reported)

VendorProductVersions
Unleash unleash < 7.5.2>= 7.6.0, < 7.6.5>= 8.0.0, < 8.0.2

Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References