Vulnerability · Published Oct 30, 2026 · Assigned by GitHub_M

CVE-2026-63402i18next: Shared built-in corruption through inherited-key deepExtend recursion

Medium 5.9

In plain English

A medium-severity prototype pollution in i18next from i18next. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities).

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 81.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

i18next is an internationalization framework for JavaScript. Prior to version 26.3.4, `deepExtend` in `src/utils.js` checks property existence with the in operator and recurses into inherited built-ins reached through `Object.prototype`. An application must explicitly pass attacker-controlled resource data to `addResourceBundle(lng, ns, data, deep, overwrite)` with both `deep: true` and `overwrite: true`. Source keys such as `hasOwnProperty`, `toString` and `valueOf` can then select shared inherited built-in function objects, and a nested value can overwrite a property of those objects process-wide. For example, making `Object.prototype.hasOwnProperty.call` non-callable causes subsequent uses, including i18next internals, to throw TypeError, resulting in unrecoverable denial of service and limited integrity impact. The `__proto__`/`constructor` guard does not prevent this mechanism because the corruption target is an inherited built-in function rather than the prototype object itself. Default calls without deep merging or with overwrite falsy are unaffected, and no standard i18next backend or integration uses the vulnerable configuration. This issue is distinct from the setPath/key-walking prototype-pollution flaws in i18next-fs-backend (CVE-2026-48713) and i18next-http-middleware (CVE-2026-48714). This issue is fixed in version 26.3.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-i18nextno fix listedDEBIAN-CVE-2026-63402
Debian:13node-i18nextno fix listedDEBIAN-CVE-2026-63402
Debian:14node-i18nextno fix listedDEBIAN-CVE-2026-63402
Ubuntu:22.04:LTSnode-i18nextno fix listedUBUNTU-CVE-2026-63402
Ubuntu:24.04:LTSnode-i18nextno fix listedUBUNTU-CVE-2026-63402
Ubuntu:26.04:LTSnode-i18nextno fix listedUBUNTU-CVE-2026-63402
Ubuntu:26.10node-i18nextno fix listedUBUNTU-CVE-2026-63402

Affected products (as reported)

VendorProductVersions
i18next i18next < 26.3.4

Weakness: CWE-471, CWE-1321 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H

References